Ask the Expert

Receiving MAPI error after uninstalling Outlook on SBS and Exchange

I installed Outlook 2003 on Small Business Server and Exchange Server. I didn't know that I wasn't supposed to do this. Now I have uninstalled Outlook from the servers, but I'm having problems -- when I try to rebuild the default global address list, I get the error "MAPI or an unspecified service provider." I think my MAPI profile may be corrupted. How can I fix this?

    Requires Free Membership to View

Backup first and then reinstall Exchange over the existing installation.

Do you have comments on this Ask the Expert Q&A? Let us know.

Related information from SearchExchange.com:

  • Expert Advice: Installing Microsoft Outlook on Exchange Server 2003
  • Tip: Exchange and Outlook shouldn't share
  • Tip: Microsoft Outlook without Exchange Server
  • Learning Center: The Microsoft Outlook Toolbox
  • Reference Center: Microsoft Outlook tips and resources
  • Reference Center: MAPl tips and resources
  • This was first published in July 2006

    There are Comments. Add yours.

     
    TIP: Want to include a code block in your comment? Use <pre> or <code> tags around the desired text. Ex: <code>insert code</code>

    REGISTER or login:

    Forgot Password?
    By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
    Sort by: OldestNewest

    Forgot Password?

    No problem! Submit your e-mail address below. We'll send you an email containing your password.

    Your password has been sent to: